Skip to end of metadata
Go to start of metadata

Builder 2.x Release Notes

Summary

Builder 2.x introduced a visual layout editor and a vast array of new customisation options. For more information on what's new in Builder 2 (hey, that rhymed!) check out Migrating from 1.x.

Some Theme Builder 2 releases are tailored to specific versions of Confluence:

  • Builder 2.0.0 - 2.0.3-conf22 were developed for Confluence 2.1.5a-2.2.x
  • Builder 2.0.4-2.0.6 were developed for Confluence 2.3.x-2.4.x
  • Builder 2.0.7 and above is recommended for use with Confluence 2.5.x and above
  • Builder 2.0.9 is recommended for use with Confluence 2.6.x

(warning) Builder 2.x is not compatible with Confluence 2.7 or above - you will require Theme Builder 3.x.

Important Notes

An upgrade from Builder 1.x to 2.x will lose some settings due to significant architectural changes. Clients upgrading from 1.x to 2.x should contact Adaptavist Support prior to performing the upgrade or alternatively start with a fresh theme layout. See Migrating from 1.x.

Please note that Builder 2.0.x does not support clustered Confluence environments.
If you are require clustering, please use Builder 3.x or above.

Requirements

Builder 2.0.x and above require that you install two additional open source plugins (developed by Adaptavist) for correct operation:

  • Page Information Tools plugin:
    • Use Version 1.2.2 for Confluence 2.0.x-2.2.x
    • Use the latest version for Confluence 2.3.x and above
  • Content Formatting Macros plugin:
    • Use latest version for all Confluence versions

These plugins are maintained on an ongoing basis by Adaptavist as they are required for the Theme Builder plugin.

Release Notes

Frequently Asked Questions

 I've set the theme at global level, why aren't spaces inheriting the theme settings?

Theme Builder 2.x customises global and space level pages separately. You can copy the global customisations to spaces by entering the global theme configuration screen and choosing "File > Download Settings" then uploading the settings file to any number of spaces by using the "File > Upload Settings..." option.

Tip: Builder 3.x and above allows the global theme settings to be automatically applied to global and personal spaces. See Default Layouts Tab for more information.

 When I click "Upload Settings..." nothing happens - why?

It's a known bug in Theme Builder 2.x - choose the option twice and the upload panel will appear.

 Where is the documentation for the Builder-specific macros?

It's under the Macros section in our user guides.

You can also find notation and examples in the "Full Notation Guide" when editing pages using the "Wiki Markup" editor.

 I've upgraded from Confluence 2.2 (or earlier) to 2.3 (or later) - where have my theme settings gone?

The Confluence upgrade process doesn't import the Theme Builder configuration files. To resolve this issue, manually copy the "/config" folder from your backup of the previous installation to the new installation and everything should return to normal. In very rare cases you might need to restart Confluence for the changes to take effect.

  • No labels