Skip to end of metadata
Go to start of metadata

I looked on the Community Bubbles downloads page but can't see it there. We are currently testing Conf 2.10.1 and plan to upgrade asap but need CB 1.1. TIA

  • No labels

7 Comments

  1. Unknown User (skrebs)

    Sorry about that, it is attached to the page: https://www.adaptavist.com/pages/viewpageattachments.action?pageId=24314012

    but not linked on the front because its not the official stable version currently. You should also be able to get this release from the plugin repository within confluence.

    1. Unknown User (tstrugar@wwf.org.au)

      Thanks. I just installed it via the Plugin Repository (PR) but there is a problem with the PR plugin which I have reported to Atlassian. That is, the repository is not correctly showing that new plugins are available for all relevant plugins it lists. In this case, the new 1.1rc1 plugin is listed but there is no upgrade link. And, the only way to upgrade this plugin (and some others too) via the repository is to first uninstall the plugin and then reinstall it (1.1rc1 is then the version that is listed for installation).

      Atlassian said that it may have something to do with metadata being upload or not by developers but I think something else might be broken in the PR plugin itself.

      1. Unknown User (gfraser)

        That's usually caused by installing a version of a plugin that's not in the repository, such as a milestone or beta release.

        When Adaptavist developed the plugin repository (it won the first ever Codegeist contest and later became a standard part of Confluence), we realised that some customers would install a bug fix release (often known as a "snapshot") they were given by tech support. As such this would often be a later release than the current public release, but won't be in the repository as it's just a "quick fix". In this scenario if you upgraded to the latest public release, you'd actually be downgrading to an earlier version that contained the bugs which were fixed by the temporary snapshot release.

        Personally I'd like the upgrade link to work even if the installed version is not in the repository - it should show a warning and ask for confirmation (as you might actually end up downgrading), then install the latest stable release IMHO. Hopefully Atlassian will change it.

        Maybe it could look at the plugin dates or something to work out if the installed version is more recent than the public release?

        Could you post this comment in to your support ticket with Atlassian?

        1. Unknown User (tstrugar@wwf.org.au)

          Thanks, that's good to know. Can't find the ticket Atlassian (may have) raised so I created a new one and added your comments: CONF-14166

    2. Unknown User (sjolar)

      I tried to install the 1.1 rc1 version, but Confluence crashed. We currently have the 1.0.3 version installed, but when attempting to install via the Plugin Repository, the system crashes. Any known issues surrounding this? Tomi points out below that one should uninstall the old plugin, then install the upgrade. Uninstall is not an available alternative, instead I find a Disable plugin alternative. I have tried both with the plugin disabled and not disabled, but with no success.

      I just wanted to check whether or not there are any known issues regarding this, before I issue a report. Do I report this with you or with Atlassian?

      1. Unknown User (skrebs)

        Firstly, what version of Confluence are you using? The 1.1 release will only support Confluence 2.8.1+.

        If you are using a supported Confluence version, please create an issue in our support project https://tracker.adaptavist.com/browse/USUP in the first instance. Include as much information as possible including the logs from when confluence crashes please. Even if the plugin has a problem it should not bring down the rest of the system.

        1. Unknown User (sjolar)

          We are currently running Confluence 2.9.1. I will create an issue for this problem.