Skip to end of metadata
Go to start of metadata

Adaptavist ThemeBuilder, next generation theming for Confluence

Atlassian’s improved user interface in Confluence 5 gave us the opportunity to refresh our approach to Confluence themes.  We kept all the best bits from previous versions and added an improved editor, more flexible layouts, and closer integration with Atlassian’s own code. So you can be sure your Confluence site customised with ThemeBuilder will look great and work smoothly.

ThemeBuilder gives you advanced control over the layout and look of your Confluence web site.  ThemeBuilder provides:

  • Nested panels based on HTML DIV elements, for enhanced flexibility of page structure.
  • Storage format compatible; write macros and HTML directly into the panel editor.
  • Wiki Markup option for conversion of existing themes.
  • Exporter feature to assist conversion of existing themes to work with Confluence 5.
  • Code base that matches the HTML5 standards used in Confluence 5.

ThemeBuilder is a powerful tool with the ability to fully customise the output of your Confluence pages.  To get the most out of it, we recommend that your theme is built and maintained by someone with web design or development experience, including knowledge of HTML/CSS.

The default editor state of ThemeBuilder uses XHTML-based Confluence Storage Format[1]. You can also use Confluence Wiki Markup[2] or plain HTML.

ThemeBuilder is accessed through the Confluence Administration and Space Administration screens. Theme editors must have a minimum of Space Administration permissions in Confluence to be able to use ThemeBuilder.

Confluence Compatibility

See ThemeBuilder on Atlassian Marketplace for more details

Confluence VersionThemeBuilder VersionNotes
5+5+

ThemeBuilder is for Confluence 5 and above.

The information in this space is for ThemeBuilder with Confluence 5.

44.3+

Theme Builder  is for Confluence 4.0 - 4.3

See Theme Builder with Confluence 4 information

3.5 and lower4.2.3 and lower

See https://marketplace.atlassian.com/plugins/com.adaptavist.confluence.themes.sitebuilder/versions

See Theme Builder with Confluence 3 and lower information

 

Upgrading from Theme Builder 4 to ThemeBuilder

Theme backups from previous versions of Theme Builder (4 and earlier) cannot be directly imported into ThemeBuilder. There are options to help you recreate a theme design in the new Skin Editor:

  • You can copy or write wiki markup directly into the new skin editor panels, or rebuild that markup as storage format using ThemeBuilder's macro insert/edit feature
  • You can use the Layout Exporter to generate skin-backup files of your old  Theme Builder layouts to use as a base for building a new  ThemeBuilder skin. Due to the differences between the confluence menu system and the old builder menus, the process of Migrating from Theme Builder 4 to ThemeBuilder 5 is not entirely straight forward and some thought should be put into completely re-developing the skin from scratch.
  • Adaptavist offers an upgrade service for conversion of previous version designs to ThemeBuilder format. Please contact us for more information and pricing.

Note that changes by Atlassian to the Confluence UI could cause some elements of a layout from previous versions to fail. You may need to redesign for ThemeBuilder and Confluence 5.

 

ThemeBuilder Information in this space

 

Plugin Support

We offer plugin related support, Product Support Service Level Agreement (SLA) for Adaptavist Products and Plugins.