Skip to end of metadata
Go to start of metadata

This affects ScriptRunner for Jira, 6.0.06.0.0-p5, 6.0.1 and 6.0.1-p5These versions have been removed from the Marketplace.


The symptoms are errors when creating issues, or moving issues in a board, or when reindexing.

As far as we understand, this can only happen when 

  • You have script fields that were last edited when you had installed a version of ScriptRunner prior to 5.10
  • You have multiple field configuration schemes for the field, where one was deleted in the past
  • You have created a custom field outside our UI, then never go and edit any other script field

Under these circumstances, you will hit these various errors. The stack traces in the log will differ, but all will have the line:

Caused by: java.lang.Exception: Missing parameters for fields

somewhere within them. This is because the configuration (eg your script, any parameters etc) for this field is missing.

We are working urgently to rectify this. 

To get your instance up and running, please visit the marketplace and install the version 6.0.2x or above.

https://marketplace.atlassian.com/apps/6820/scriptrunner-for-jira/version-history

Downgrading

Please do not downgrade ScriptRunner to a prior version. Downgrading is not supported.