Skip to end of metadata
Go to start of metadata

In version 1.0.8, we have changed the way custom fields are identified in the XML configuration file. Since that version, custom fields are identified by a composite key made up from their type and key. This change was implemented as part of adding support for custom fields with duplicate field names.

As a result, new plugin versions expect to find these composite keys whenever there is a reference to a custom field. On the other hand, versions 1.0.7 and earlier identify custom fields just by their name. This means versions 1.0.8 and later will not be able to load correctly files exported by versions 1.0.7 and earlier.

How to upgrade XML files

If you have XML configuration files exported by versions 1.0.7 or earlier and want to load them with version 1.0.8 of the plugin, use this XSLT file to process the existing files and create new ones that can be loaded by version 1.0.8.

UpgradeXMLConfigFilesToV_1-0-8.xslt

You can use any XSLT2 compliant processor with this file. For example, using AltovaXML Community Edition, the command line would be like:

AltovaXML -xslt2 UpgradeXMLConfigFilesToV_1-0-8.xslt -in InputFile -out OutputFile

where InputFile is the file generated by v1.0.7 or earlier of the plugin, and OutputFile is the name you want to give to the new XML configuration file that can be loaded by version 1.0.8.

  • No labels