Skip to end of metadata
Go to start of metadata

Builder 4.1.3 will not install properly on Confluence 3.3.3 through the plugin repository (it fetches version 3.3.3).
When manually installing version 4.1.3, after installing Page Information Tools 1.2.2 and Content Formatting Macros 1.6.16, it fails with the following errors:

There were errors loading this plugin. There is more information in the logs.

Cause:
There was a problem loading the descriptor for module 'Colour Scheme Change Listener' in plugin 'Adaptavist Theme Builder'. java.lang.StringIndexOutOfBoundsException: String index out of range: -1

Log extract:

2010-09-21 08:19:08,198 WARN http-8080-3 macro.browser.beans.MacroParameterType get Unknown type: false
– referer: http://ubiquitic.com/admin/plugin-repository/plugins.action | url: /plugins/servlet/plugin-repository/dwr/exec/RepositoryDWR.installPluginFromExternalSource.dwr | userName: admin
2010-09-21 08:19:08,283 WARN http-8080-3 macro.browser.beans.MacroParameterType get Unknown type: null
– referer: http://ubiquitic.com/admin/plugin-repository/plugins.action | url: /plugins/servlet/plugin-repository/dwr/exec/RepositoryDWR.installPluginFromExternalSource.dwr | userName: admin
2010-09-21 08:19:08,316 ERROR http-8080-3 atlassian.plugin.manager.DefaultPluginManager enableConfiguredPluginModule There was an error loading the descriptor 'Colour Scheme Change Listener' of plugin 'com.adaptavist.confluence.themes.sitebuilder'. Disabling.
– referer: http://ubiquitic.com/admin/plugin-repository/plugins.action | url: /plugins/servlet/plugin-repository/dwr/exec/RepositoryDWR.installPluginFromExternalSource.dwr | userName: admin
com.atlassian.plugin.PluginParseException: java.lang.StringIndexOutOfBoundsException: String index out of range: -1

  • No labels

6 Comments

  1. Unknown User (kbrophy)

    Hi Francois,

    Many thanks for this report.

    In local testing, Builder did install correctly (including the Colour Scheme Change Listener module). However, due to the deprecation of the DWR within Confluence, various elements of Builder will fail to operate correctly (e.g. Manage Builder Layouts).

    The issue has been raised with the Builder development team, but due to other project commitments, the tentative time-line for addressing this problem has been pushed out to the start of November 2010.

    Where Builder is a core element of your Confluence site, I would suggest remaining on a previous version of Confluence until this issue is resolved.

    Cheers,
    Keith

    1. Unknown User (snerd)

      That's a shame - there are some important security fixes in 3.3.3 that I'm uncomfortable downgrading into (cf: http://confluence.atlassian.com/display/DOC/Confluence+Security+Advisory+2010-09-21)

      I'm currently building out a new instance o Confluence/Builder and waiting until November is pretty inconvenient.

  2. Unknown User (diggo)

    Does this apply for 3.4 as well? Dont really want to wait util November to deploy 3.4

    1. Unknown User (diggo)

      Does this issue only apply to instances where Builder 4.13 is NOT already installed?

      In other words, will Builder 4.13 continue to function if an existing 3.3.1 instance is upgraded to 3.4?

      Thanks

      1. Unknown User (diggo)

        aah well, I checked in a test instance and pagetree2 doesn't work in Conf 3.4

        "loading...."

        Sean

        1. Unknown User (kbrophy)

          Hi Sean,

          Unfortunately, as you have discovered, this issue will be present in the latest Confluence release also. We are currently working on verifying our plugin list for 3.4 compatibility at the moment, but the work required for Theme Builder is still scheduled for the start of November. Should any break in the project schedules appear, we shall certainly endeavour to address these issues sooner.

          Regards,
          Keith