Skip to end of metadata
Go to start of metadata

Hi,

I am in the process of building a custom theme with a custom menu. I have just about all of the menu items that I need working except for setting and removing Sticky tags on forum posts.

I have tried two different menu macros, these:

{menuitem}{menuicon:pin_blue}{menulink:forum-sticky}Add Sticky...{menulink}{menuitem}

{compound-menuitem:set-sticky|caption=Set sticky topic}

that I found by searching here. Neither one is working. Whether I am just viewing or editing a topic, the Sticky menu items do not appear on the menu.

Anyone know what I can do to get this to work?

Thanks.

  • No labels

7 Comments

  1. Unknown User (gfraser)

    Have you clicked the button under the forum macro on the parent page to enable forum features? Until that's done the sticky links won't appear IIRC.

    1. Unknown User (katerk)

      Yes, the forum features are enabled.

      Kate

      1. Unknown User (gfraser)

        What privileges do you have in the space? In Space Admin there's a setting that determines who can set sticky topics.

        Also, did you add the aliases (set-sticky, forum-sticky) in Theme Builder admin Menulink Aliases Tab?

        1. Unknown User (katerk)

          When I click on that tab, there are no plugins in the drop-down. We have several dozen plugins isntalled but none show.

          Kate

  2. Unknown User (dan.feeley@protegrity.com)

    greetings,

    I have the pinning option working as described above, but I cannot get the icons to work. Any suggestions? Here is what I have:

    {compound-menuitem:set-sticky|icon=pin_blue|tooltip=Set sticky topic|flat=true|imginside=true}
    {compound-menuitem:remove-sticky|icon=pin_gray|tooltip=remove sticky 
    
    1. Unknown User (tewolff)

      You might try spelling the second one "pin_grey". That's the way I have it and I don't know if both spellings work.

      1. Yep, it's always worth using the correct spelling of a word! See: wikipedia