Skip to end of metadata
Go to start of metadata

One of our users has requested that we install Community Bubbles for the Forum feature. We are on Confluence 2.10.3 and I installed Bubbles 1.5.2 this morning (on our Dev server).

The first time I added the forum macro to a page, I got prompted to set it up with forum features. I even added the Add-Topic macro to the page and added topics through it.

The result? Nothing. The child pages show in the tree but even after two hours (just in case it was indexing), I have nothing showing in the Topics table.

So, what am I missing???? Is there a guide somewhere to set up a forum? Or is it a problem with our version?

Thanks for any help you can provide.

Kate

  • No labels

15 Comments

  1. That sounds like a problem with lucene ... are you seeing any exceptions in the logs?

    1. Unknown User (gfraser)

      Also, check that the indexing components of the plugin are enabled in the plugin manager (in confluence admin console).

  2. Unknown User (katerk)

    Alain,

    I am new to Confluence wiki adminstration. What is Lucene and in which log would I look for errors?

    Guy,

    The following three components were not enabled. I enabled them and still had the same result. The only other one not enabled is the widget which apparently causes conflicts.

    I enabled these three:

    my-recent-edits
    User Profile Recent Edits Tab Web Item
    User Profile Recent Edits Menu Link

    and still no topics in the forum. I need advice on how to move forward from here.

    Thanks.

    Kate

    1. Unknown User (gfraser)

      In Confluence admin console, go in to Indexing and there should be a link to rebuild search indexes.

      Note that topics are child pages of the page where you've used the forum macro, unless you specify a different page with the 'page' parameter.

  3. Unknown User (katerk)

    Update:

    The three topics that I posted last Thursday and Friday (10/1 - 10/2/09) showed up this morning. I then replied to one of the topics, Topic two, by adding a child page to it. The reply did not show.

    Do you think that this (Development) server could be set for an infrequent indexing schedule? If so, how would I change that?

    I'm going to make an educated guess that our users will want much more frequent updating of the forum than once a week or so.

    So just to test things, I rebuilt the index and the result was this, a forum table that showed each of the three topics twice. As in Topic three, three, two, two, one, one, each on a separate line of the topic table. But the pagetree shows only one instance of each page (which is correct). The reply to Topic two did not show up after the reindex.

    Any suggestions on what to do next?

    Thanks.

    Kate

    1. Unknown User (katerk)

      OK, so I was able to get this working in another space. I have no idea why it would not work in the first one.

      Now, I am experiencing another problem, which wa reported here but never answered:

      https://www.adaptavist.com/display/Bubbles/Issue+with+Forum+Macro

      My screen gets cut off at the comment tool bar and I cannot add any text.

      This is becoming very frustrating as I have a major user group (3500+) requesting this forum function. I am going to have to direct them to another product to be able to accommodate their request.

      1. Unknown User (skrebs)

        The issue with topics showing up multiple times in the forum sounds like something has gone wrong with the indexing on your site. If you do a search in confluence for the content within one of those topics do results show up twice?

        The issue you linked to above where the comments section isn't displayed is probably a problem with the themebuilder plugin rather then the bubbles forum as such. Alain's suggestion on the topic you linked to was to upgrade to the latest version of themebuilder.

        1. Unknown User (katerk)

          Shannon,

          The topics showing up multiple times disappeared after a re-index.

          My testing with the other problems is showing that the forum problem is indeed related to Theme Builder. If I use any of the standard Conluence themes, everything in the forum works perfectly. As soon as I switch to a Theme Builder layout, I start having the problems again.

          I will upgrade to the latest Theme Builder.

          Thanks.

        2. Unknown User (katerk)

          OK, well we are already using what appears to be the latest, Plugin Version: 3.3.5-conf210 for our 2.10.3 instance. I uploaded it again anyways and the results are still the same. Problems with the forum, not being able to make comments (section is not available) as before.

          Any other suggestions?

          1. Unknown User (gfraser)

            If the comments section is not appearing, has someone altered the theme config to remove the builder-comments macro from the footer panel? Also, check that the 'display comments by defualt' box is checked (on the options tab in layout manager IIRC).

            1. One quick way of checking whether it is your layout config is to append ?layout=DEFAULT to the URL (or &layout=DEFAULT if the URL already contains a '?') ... this will tell builder to ignore your layout selection for that page view & use the default layout instead.

              There are no known problems with builder & bubbles running on confluence 2.10.3 that would cause this kind of issue with the default layout.

            2. Unknown User (katerk)

              Well, very interesting!

              {builder-comments} was indeed missing from the footnotes panel. I must have copied someone's theme where they removed that. I also wonder why it would have just cut off the comment content section, leaving the toolbar.

              OK, now that I can make and see comments, is there any way to style them like the default comments? Or at least indent them slightly to make them appear more "threaded"? I like the "Reply To This" option that is not on the builder-comments.

              Seriously, thanks for all your help in troubleshooting this. I will now have some very happy users.

              Kate

              1. Unknown User (gfraser)

                If they're not indenting then there could be two scenarios:

                1. Threaded comments are disabled in Confluence admin console (under General Configuration from memory)
                2. Someone's removed or overridden the CSS used to indent them (in which case look though the CSS settings for the Builder layout you're using to see if there's anything that looks like mods to the comments CSS)
              2. {builder-comments} is just a pass-through to the atlassian code, it will be rendering whatever the atlassian comments.vmd has been set to do. If you have edited this through the atlassian 'layouts' functionality then this will be affecting builder.

                I'm glad you have found the problem though, in future try and remember the layout=DEFAULT trick as it is a nice easy way to check whether the problem originates in your layout or in the builder/confluence source.

                1. Unknown User (katerk)

                  Yes, thanks for that trick, it is in my notes now for future use.