Skip to end of metadata
Go to start of metadata

Error message: I tried the invite function today with another user who reported that she received an error message that she had not been invited. I tried it myself by inviting my personal ID to join a Community. Indeed, here is the message I got after activating the Accept Link:An Error ocurred [sic]
The following error(s) occurred:
You have not been invited to join this community
Clearly something isn't setup right with our wiki or with the functionality. It turned out that the error message came up on a pre-login page, i.e. there was a Login link in the top menu bar even though I was already logged in in a different IE window. I decided to try the login link anyway and sure enough, I managed to login via a different ID in a different IE screen. Very odd: two separate concurrent login sessions. After logging in, I was taken to http://wiki.piug.org/users/bubbles/user-community-profile.action which identified the proper space that I was invited to and that "You are an administrator for this community." My personal ID should not have been made an admin. I clicked on the link for View Members and I was in fact added as a member of the Community by this overall process. I can't tell who are the Admins from that screen (http://wiki.piug.org/bubbles/community-members.action?key=biotech). From that page I clicked on Admin Options link and just got a page error message: "Done, but with errors on the page."

I decided that maybe the system was confused because I was logged with two usernames at the same time. I logged of both and tried again with just my admin username, but no change on that Admin Options link.

More odd behaviour. I decided to click on the Accept link again to see what happened. I got this messageAn Error ocurred
The following error(s) occurred:
You are already a member of this community
That's good but then I tried the <<Back link. It took me to http://wiki.piug.org/users/bubbles/user-community-profile.action which would have been OK except that the content (which Communities I was a member of) showed up under the Watches tab. I confirmed that clicking on the Community Membership tab gave the same output but still under the Watches tab. I had to leave that page and then click on Watches to get the proper watches output.

How do I remove my personal ID as a community member? I don't see any means to remove members other than under the Admin Console for Community Bubbles to remove user from All Communities, not ban them but remove them in case they no longer are part of the community.

I saw some other functionality for Community management in a tabbed screen but can't find it again. I think I am still missing some functionality besides the main page http://wiki.piug.org/bubbles/community-members.action?key=biotech. Maybe I found another Admin Options page other than the link that I described above that doesn't work.

I look forward to working out these matters with you.

Tom

  • No labels

3 Comments

  1. Unknown User (skrebs)

    There has been some bugs fixed in relation to the invite process and making sure users are logged in recently, these will be available in the next milestone release, hopefully soon.

    If you have permission to admin the space (i.e you are a site admin) you will also be a community admin, this might be why it showed you as being a community admin once you became a member?

    Regarding the community membership tab showing up under the watchers tab, this is due to a bug in Confluence. It is fixed in confluence 2.9 and there should be some javascript to make it look correct in 2.8, but previous versions don't work correctly. It looks like you are running Confluence 2.8.2 so I'm guessing its either a problem with the theme or not having javascript turned on :-\

    To remove your personal id as a community member you need to use the community members screen as an admin. Click on members then admin options put your username in the text box, select Remove Community Members then hit submit. That should remove the specified user from all of the community lists.

    1. Unknown User (tewolff)

      I'm sure you are busy with the next milestone release. Let me know if you need any input from me. 

      You wrote: "Click on members then admin options". That is functionality that I said doesn't work: "From that page I clicked on Admin Options link and just got a page error message: "Done, but with errors on the page."" This is from my admin username. I decided to try this from another computer to be sure it wasn't a problem with my laptop or its loading of IE 7. The second computer has the same configuration and gives the same page error message when I try to get to Admin Options. So what could be causing this? Should I be putting in a separate trouble ticket for this?

      As you know, Sandra recently got me working admin access to the http://wiki.piug.org/bubbles/community-members.action?&nbsp;pages. Let me ask another way: are there other Community Bubbles configuration or function pages that I should have access to and perhaps should be providing users or admins links to?

      I was wrong about my personal username tomwolff not being a space admin, so it was correct to indicate that  tomwolff was a community administrator. Removing space admin rights removed community admin rights as appropriate.

      It seems you are going to consider all that peculiar behaviour of parallel simultaneous logins as a Confluence peculiarity. So be it.

      Should I be turning on Javascript somewhere in the Admin Console?

      At what point should I be considering upgrading Confluence? Is that something I would do myself?

      1. Unknown User (skrebs)

        It sounds like there are some javascript issues with the theme customisations that have been made to your site. Please create a ticket for us to investigate, I suspect we need to include the jquery library with your theme.

        I'm not sure about the login issue, it shouldn't happen. If you can still reproduce the problem once the next build is available please let us know.

        I'm not really familiar with the customisations that have been made to your site, so can't say for sure if you are missing any links, the profile tab and the community member space tab are the main links for the communities functionality which it sounds like you have now.