Skip to end of metadata
Go to start of metadata

Hi, when I click "email users" in the administration dashboard, I get the Confluence Oops!

Cause:
com.opensymphony.xwork.config.ConfigurationException: There is no Action mapped for namespace /admin/bubbles and action name emailusers
at com.opensymphony.xwork.DefaultActionProxy.(DefaultActionProxy.java:72)

Stack Trace: hide

com.opensymphony.xwork.config.ConfigurationException: There is no Action mapped for namespace /admin/bubbles and action name emailusers
at com.opensymphony.xwork.DefaultActionProxy.(DefaultActionProxy.java:72)
at com.opensymphony.xwork.DefaultActionProxyFactory.createActionProxy(DefaultActionProxyFactory.java:45)
at com.opensymphony.webwork.dispatcher.ServletDispatcher.serviceAction(ServletDispatcher.java:227)
at com.opensymphony.webwork.dispatcher.ServletDispatcher.service(ServletDispatcher.java:199)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterCh

Also, when I'm doing space admin, and I click: Community Bubbles Community Settings, I get:

Cause:
com.opensymphony.xwork.config.ConfigurationException: There is no Action mapped for namespace /bubbles and action name community-config
at com.opensymphony.xwork.DefaultActionProxy.(DefaultActionProxy.java:72)

Stack Trace: hide

com.opensymphony.xwork.config.ConfigurationException: There is no Action mapped for namespace /bubbles and action name community-config
at com.opensymphony.xwork.DefaultActionProxy.(DefaultActionProxy.java:72)
at com.opensymphony.xwork.DefaultActionProxyFactory.createActionProxy(DefaultActionProxyFactory.java:45)
at com.opensymphony.webwork.dispatcher.ServletDispatcher.serviceAction(ServletDispatcher.java:227)
at com.opensymphony.webwork.dispatcher.ServletDispatcher.service(ServletDispatcher.java:199)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter

Our Confluence is setup to be /confluence/ as the root... not / ... could this be the problem that bubbles isn't picking up on it?

v0.9.54.

This is v0.9.54.

  • No labels

8 Comments

  1. No .. more likely I didnt uncomment the email users xwork action declaration .. the copy of bubbles you are using is severely restricted, there is a wealth more code in there but the majority of it is disabled until such time as we can get the documentation finished.

    Please create an issue at tracker.adaptavist.com and I will upload you a snapshot of 0.9.57 - yes quite a bit of dev work has been going on behind the scenes (wink)

  2. Unknown User (dudester)

    Hi Alain,

    The "Email Users" feature worked for me; the problem is that it only sent the first line of the email message.

    I am using adaptavist-plugin-bubbles-0.9.54.jar on a free Confluence Evaluation License.

    Thanks.

    1. Unknown User (gfraser)

      Which version of Confluence are you running?

      1. Unknown User (dudester)

        Hello Guy - i have version 2.7.3

        Thanks

        1. Unknown User (dudester)

          For example, here is what I tried to send:

          ----------------------
          A free version of the Community Bubbles Plugin (works only with Confluence Evaluation License) is now installed. An immediate benefit from this plugin is the ability to "force" users to watch the entire site, a space, or a page.

          For demonstration purposes, I have identified all our admin user accounts to watch the entire site. If you want to remove your account from this, go to the Administration page and scroll down to the sub-category "Community Bubbles". Click the link "Site Watchers" to display the list of users watching the entire site. Click the red "x" mark next to your name.

          I will be testing other functionality of this plugin in the coming days and document them here.

          ------------------

          Here is the email i got:

          ------------------

          A free version of the Community Bubbles Plugin (works only with Confluence Evaluation License) is now installed. An immediate benefit from this plugin is the ability to

          ------------------

          It seems to not like the quotation mark, since the sent content terminated before it (maybe it does not accept other ASCII characters too).

          Thanks,
          Doods

          1. Unknown User (skrebs)

            Thanks for testing this, and identifying the problem. I can reproduce this at my end and have created an issue here:

            http://jira.adaptavist.com/browse/BUBBLES-253

  3. Unknown User (gormans)

    Hi, I'm fairly new to Confluence and have installed the Bubbles plugin.

     I created a page with the macro on it, but I cannot figure out why I'm not seeing the forum. I've installed the plugin in our testing environment and we do have an evaluation license.

    Here is what I'm seeing after adding the forum macro.

    Thanks for the help and guidance.

     

    1. Add a child page ... or better still add a copy of the {add-topic} macro to that page so that your users have an obvious way of adding topics/pages (wink)