Skip to end of metadata
Go to start of metadata

I have followed the instructions on the page https://www.adaptavist.com/display/Bubbles/Community+Types and assigned communities to different types but the X is not showing up and the old community types cannot be removed.

I had initially named my Community Types by an ID number but it appears that it was supposed to be named as a word.

Regards

CV

  • No labels

8 Comments

  1. Unknown User (skrebs)

    If you put the communities macro on an arbitrary page with the ID you want to delete does it show any Spaces?

    1. Unknown User (orthonet)

      Shannon

      If I put communities macro

      {communities:PROGRAM}

      or

      {communities:3}

      I do not get anything showing up.

      Iniitally I setup the community types using an id number but then I changed it to a name ie. PROGRAM, ALUMNI, MAILING_LIST
      I subsequently changed the communities to have the new types.

      Prior to this I was unable to get the communities macro to work also. I thought it was because the community types were id numbers. But that does not appear to make a difference.

      If I do not include the :PROGRAM or :3 then it gives an error that community type is required.

      Any ideas.

      Regards

      CV

      1. Unknown User (skrebs)

        If you create a new community type, but don't setup any communities with it, does it let you delete it, or does that not work as well?

        1. Unknown User (orthonet)

          That works fine.
          In fact I removed 3 of the previously created community types 2,4,5

          It is only the ones that were previously assigned ie. 1 and 3 that I cannot remove despite changing the previous communities that used that type to the new types.
          1 changed to MAILING_LIST
          3 changed to PROGRAM

          Have 2.10.1 and 1.2 bubbles installed.

          Regards

          CV

        2. Unknown User (skrebs)

          I've tested this a bit myself and it does appear to have some bugs. If you haven't already setup lots of members in the community, you could try removing the community settings completely from the spaces where it was originally set, I have had some success with that. Before recreating the community with the correct type.

          I have created a bug report here: http://jira.adaptavist.com/browse/BUBBLES-317 which we will try to address in the next release cycle.

          1. Unknown User (orthonet)

            Thanks
            Will give it a try.

            Regards

            CV

          2. Unknown User (skrebs)

            I have fixed the bug where we are not correctly removing the space key from the list of spaces for each community type when you update the community type on a space. Since the Community Type thinks it is still being used it will not let you delete it. Also I found that the communities macro was defaulting to communities with Open enrolment, not all enrolment types as the documentation indicates.

            Both of these have been fixed and will be available in the next point release of Bubbles. In the meantime I have attached a SNAPSHOT build to this page which also contains these fixes.

            adaptavist-plugin-bubbles-1.2.2-SNAPSHOT-20090319.jar

            (You may need to update the community type of a space to actually get it to clear the internal list again, before you will be able to remove the old community types.)

            1. Unknown User (orthonet)

              Works
              Thanks

              CV